• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/newt/newt.mk
Samuel MartinSamuel Martin committed a34896a8d7e11 Oct 2012
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
#############################################################
#
# newt
#
#############################################################
NEWT_VERSION         = 0.51.0
NEWT_SITE            = http://www.uclibc.org/
NEWT_SOURCE          = newt-$(NEWT_VERSION).tar.bz2
NEWT_LICENSE         = GPLv2
NEWT_LICENSE_FILES   = COPYING
NEWT_INSTALL_STAGING = YES
​
NEWT_DEPENDENCIES = slang
​
NEWT_MAKE_ENV += $(TARGET_CONFIGURE_OPTS)
NEWT_MAKE = $(MAKE1)
​
define NEWT_INSTALL_STAGING_CMDS
    $(INSTALL) -D -m644 $(@D)/newt.h    $(STAGING_DIR)/usr/include/newt.h
    $(INSTALL) -D -m644 $(@D)/libnewt.a $(STAGING_DIR)/usr/lib/libnewt.a
    $(INSTALL) -m755 $(@D)/libnewt.so*  $(STAGING_DIR)/usr/lib/
    ln -fs libnewt.so.$(NEWT_VERSION)   $(STAGING_DIR)/usr/lib/libnewt.so
    ln -fs libnewt.so.$(NEWT_VERSION)   $(STAGING_DIR)/usr/lib/libnewt.so.0.51
endef
​
define NEWT_INSTALL_TARGET_CMDS
    $(INSTALL) -D -m644 $(@D)/newt.h    $(TARGET_DIR)/usr/include/newt.h
    $(INSTALL) -D -m644 $(@D)/libnewt.a $(TARGET_DIR)/usr/lib/libnewt.a
    $(INSTALL) -m755 $(@D)/libnewt.so*  $(TARGET_DIR)/usr/lib/
    ln -fs libnewt.so.$(NEWT_VERSION)   $(TARGET_DIR)/usr/lib/libnewt.so
    ln -fs libnewt.so.$(NEWT_VERSION)   $(TARGET_DIR)/usr/lib/libnewt.so.0.51
endef
​
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.