• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/nginx/nginx.mk
Gustavo ZacariasGustavo Zacarias committed 9f04805b61304 Jun 2016
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# nginx
4
#
5
################################################################################
6
​
7
NGINX_VERSION = 1.10.1
8
NGINX_SITE = http://nginx.org/download
9
NGINX_LICENSE = BSD-2c
10
NGINX_LICENSE_FILES = LICENSE
11
NGINX_DEPENDENCIES = host-pkgconf
12
​
13
NGINX_CONF_OPTS = \
14
    --crossbuild=Linux::$(BR2_ARCH) \
15
    --with-cc="$(TARGET_CC)" \
16
    --with-cpp="$(TARGET_CC)" \
17
    --with-ld-opt="$(TARGET_LDFLAGS)" \
18
    --with-ipv6
19
​
20
# www-data user and group are used for nginx. Because these user and group
21
# are already set by buildroot, it is not necessary to redefine them.
22
# See system/skeleton/etc/passwd
23
#   username: www-data    uid: 33
24
#   groupname: www-data   gid: 33
25
#
26
# So, we just need to create the directories used by nginx with the right
27
# ownership.
28
define NGINX_PERMISSIONS
29
    /var/lib/nginx d 755 33 33 - - - - -
30
endef
31
​
32
# disable external libatomic_ops because its detection fails.
33
NGINX_CONF_ENV += \
34
    ngx_force_c_compiler=yes \
35
    ngx_force_c99_have_variadic_macros=yes \
36
    ngx_force_gcc_have_variadic_macros=yes \
37
    ngx_force_gcc_have_atomic=yes \
38
    ngx_force_have_epoll=yes \
39
    ngx_force_have_sendfile=yes \
40
    ngx_force_have_sendfile64=yes \
41
    ngx_force_have_pr_set_dumpable=yes \
42
    ngx_force_have_timer_event=yes \
43
    ngx_force_have_map_anon=yes \
44
    ngx_force_have_map_devzero=yes \
45
    ngx_force_have_sysvshm=yes \
46
    ngx_force_have_posix_sem=yes
47
​
48
# prefix: nginx root configuration location
49
NGINX_CONF_OPTS += \
50
    --prefix=/usr \
51
    --conf-path=/etc/nginx/nginx.conf \
52
    --sbin-path=/usr/sbin/nginx \
53
    --pid-path=/var/run/nginx.pid \
54
    --lock-path=/var/run/lock/nginx.lock \
55
    --user=www-data \
56
    --group=www-data \
57
    --error-log-path=/var/log/nginx/error.log \
58
    --http-log-path=/var/log/nginx/access.log \
59
    --http-client-body-temp-path=/var/tmp/nginx/client-body \
60
    --http-proxy-temp-path=/var/tmp/nginx/proxy \
61
    --http-fastcgi-temp-path=/var/tmp/nginx/fastcgi \
62
    --http-scgi-temp-path=/var/tmp/nginx/scgi \
63
    --http-uwsgi-temp-path=/var/tmp/nginx/uwsgi
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.