• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/perl/perl.mk
Thomas De SchampheleireThomas De Schampheleire committed 3d86d29bf0507 Dec 2013
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# perl
4
#
5
################################################################################
6
​
7
PERL_VERSION_MAJOR = 18
8
PERL_VERSION = 5.$(PERL_VERSION_MAJOR).1
9
PERL_SITE = http://www.cpan.org/src/5.0
10
PERL_SOURCE = perl-$(PERL_VERSION).tar.bz2
11
PERL_LICENSE = Artistic or GPLv1+
12
PERL_LICENSE_FILES = Artistic Copying README
13
PERL_INSTALL_STAGING = YES
14
​
15
PERL_CROSS_VERSION = 0.8.3
16
PERL_CROSS_BASE_VERSION = 5.$(PERL_VERSION_MAJOR).1
17
PERL_CROSS_SITE    = http://download.berlios.de/perlcross
18
PERL_CROSS_SOURCE  = perl-$(PERL_CROSS_BASE_VERSION)-cross-$(PERL_CROSS_VERSION).tar.gz
19
PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod
20
PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
21
​
22
# We use the perlcross hack to cross-compile perl. It should
23
# be extracted over the perl sources, so we don't define that
24
# as a separate package. Instead, it is downloaded and extracted
25
# together with perl
26
​
27
define PERL_CROSS_DOWNLOAD
28
    $(call DOWNLOAD,$(PERL_CROSS_SITE:/=)/$(PERL_CROSS_SOURCE))
29
endef
30
PERL_POST_DOWNLOAD_HOOKS += PERL_CROSS_DOWNLOAD
31
​
32
define PERL_CROSS_EXTRACT
33
    $(call suitable-extractor,$(PERL_CROSS_SOURCE)) $(DL_DIR)/$(PERL_CROSS_SOURCE) | \
34
    $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
35
endef
36
PERL_POST_EXTRACT_HOOKS += PERL_CROSS_EXTRACT
37
​
38
define PERL_CROSS_SET_POD
39
    $(SED) s/$(PERL_CROSS_OLD_POD)/$(PERL_CROSS_NEW_POD)/g $(@D)/Makefile
40
endef
41
PERL_POST_PATCH_HOOKS += PERL_CROSS_SET_POD
42
​
43
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
44
    PERL_DEPENDENCIES += berkeleydb
45
endif
46
ifeq ($(BR2_PACKAGE_GDBM),y)
47
    PERL_DEPENDENCIES += gdbm
48
endif
49
​
50
# We have to override LD, because an external multilib toolchain ld is not
51
# wrapped to provide the required sysroot options.  We also can't use ccache
52
# because the configure script doesn't support it.
53
PERL_CONF_OPT = \
54
    --target=$(GNU_TARGET_NAME) \
55
    --target-tools-prefix=$(TARGET_CROSS) \
56
    --prefix=/usr \
57
    -Dld="$(TARGET_CC_NOCCACHE)" \
58
    -Dccflags="$(TARGET_CFLAGS)" \
59
    -Dldflags="$(TARGET_LDFLAGS) -lm" \
60
    -Dmydomain="" \
61
    -Dmyhostname="$(BR2_TARGET_GENERIC_HOSTNAME)" \
62
    -Dmyuname="Buildroot $(BR2_VERSION_FULL)" \
63
    -Dosname=linux \
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.