• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/php-yaml/php-yaml.mk
Gustavo ZacariasGustavo Zacarias committed 534039b329728 Jan 2014
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# php-yaml
4
#
5
################################################################################
6
​
7
PHP_YAML_VERSION = 1.1.1
8
PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
9
PHP_YAML_SITE = http://pecl.php.net/get
10
PHP_YAML_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
11
    --with-yaml=$(STAGING_DIR)/usr
12
# phpize does the autoconf magic
13
PHP_YAML_DEPENDENCIES = libyaml php host-autoconf
14
PHP_YAML_LICENSE = MIT
15
PHP_YAML_LICENSE_FILES = LICENSE
16
​
17
define PHP_YAML_PHPIZE
18
    (cd $(@D); \
19
        PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
20
        PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
21
        $(STAGING_DIR)/usr/bin/phpize)
22
endef
23
​
24
PHP_YAML_PRE_CONFIGURE_HOOKS += PHP_YAML_PHPIZE
25
​
26
$(eval $(autotools-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.