• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/pptp-linux/pptp-linux.mk
Thomas De SchampheleireThomas De Schampheleire committed eb7bd9ef61705 Dec 2013
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# pptp-linux
4
#
5
################################################################################
6
​
7
PPTP_LINUX_VERSION = 1.7.2
8
PPTP_LINUX_SITE = http://downloads.sourceforge.net/project/pptpclient/pptp/pptp-$(PPTP_LINUX_VERSION)
9
PPTP_LINUX_SOURCE = pptp-$(PPTP_LINUX_VERSION).tar.gz
10
PPTP_LINUX_MAKE = $(MAKE1)
11
PPTP_LINUX_LICENSE = GPLv2+
12
PPTP_LINUX_LICENSE_FILES = COPYING
13
​
14
define PPTP_LINUX_BUILD_CMDS
15
    $(MAKE) -C $(@D) OPTIMIZE= DEBUG= \
16
        CC="$(TARGET_CC)" \
17
        CFLAGS="$(TARGET_CFLAGS)" \
18
        LDFLAGS="$(TARGET_LDFLAGS)"
19
endef
20
​
21
define PPTP_LINUX_INSTALL_TARGET_CMDS
22
    $(INSTALL) -m 0755 -D $(@D)/pptp $(TARGET_DIR)/usr/sbin/pptp
23
    $(INSTALL) -m 0644 -D $(@D)/pptp.8 $(TARGET_DIR)/usr/share/man/man8/pptp.8
24
endef
25
​
26
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.