• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/python-pyzmq/python-pyzmq.mk
Simon DawsonSimon Dawson committed ab836f14e6202 Jan 2014
Raw file
Source viewDiff to previous
 
1
################################################################################
2
#
3
# python-pyzmq
4
#
5
################################################################################
6
​
7
PYTHON_PYZMQ_VERSION = 13.1.0
8
PYTHON_PYZMQ_SOURCE = pyzmq-$(PYTHON_PYZMQ_VERSION).tar.gz
9
PYTHON_PYZMQ_SITE = http://pypi.python.org/packages/source/p/pyzmq/
10
PYTHON_PYZMQ_LICENSE = LGPLv3+ BSD-3c Apache-2.0
11
# Apache license only online: http://www.apache.org/licenses/LICENSE-2.0
12
PYTHON_PYZMQ_LICENSE_FILES = COPYING.LESSER COPYING.BSD
13
PYTHON_PYZMQ_DEPENDENCIES = zeromq
14
PYTHON_PYZMQ_SETUP_TYPE = distutils
15
​
16
# Due to issues with cross-compiling, hardcode to the zeromq in BR
17
define PYTHON_PYZMQ_PATCH_ZEROMQ_VERSION
18
    $(SED) 's/##ZEROMQ_VERSION##/$(ZEROMQ_VERSION)/' \
19
        $(@D)/buildutils/detect.py
20
endef
21
​
22
PYTHON_PYZMQ_POST_PATCH_HOOKS += PYTHON_PYZMQ_PATCH_ZEROMQ_VERSION
23
​
24
$(eval $(python-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.