• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/qemu/qemu.mk
Yann E. MORINYann E. MORIN committed 5c8b0e6166e16 Dec 2012
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
#############################################################
2
#
3
# qemu
4
#
5
#############################################################
6
​
7
QEMU_VERSION = 1.2.2
8
QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.bz2
9
QEMU_SITE = http://wiki.qemu.org/download
10
QEMU_LICENSE = GPLv2 LGPLv2.1 MIT BSD-3c BSD-2c Others/BSD-1c
11
QEMU_LICENSE_FILES = COPYING COPYING.LIB
12
# NOTE: there is no top-level license file for non-(L)GPL licenses;
13
#       the non-(L)GPL license texts are specified in the affected
14
#       individual source files.
15
​
16
#-------------------------------------------------------------
17
# Host-qemu
18
​
19
HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2
20
​
21
#       BR ARCH         qemu
22
#       -------         ----
23
#       arm             arm
24
#       armeb           armeb
25
#       avr32           not supported
26
#       bfin            not supported
27
#       i386            i386
28
#       i486            i386
29
#       i586            i386
30
#       i686            i386
31
#       x86_64          x86_64
32
#       m68k            m68k
33
#       microblaze      microblaze
34
#       mips            mips
35
#       mipsel          mipsel
36
#       mips64          ?
37
#       mips64el        ?
38
#       powerpc         ppc
39
#       sh2             not supported
40
#       sh2a            not supported
41
#       sh3             not supported
42
#       sh3eb           not supported
43
#       sh4             sh4
44
#       sh4eb           sh4eb
45
#       sh4a            ?
46
#       sh4aeb          ?
47
#       sh64            not supported
48
#       sparc           sparc
49
​
50
HOST_QEMU_ARCH = $(ARCH)
51
ifeq ($(HOST_QEMU_ARCH),i486)
52
    HOST_QEMU_ARCH = i386
53
endif
54
ifeq ($(HOST_QEMU_ARCH),i586)
55
    HOST_QEMU_ARCH = i386
56
endif
57
ifeq ($(HOST_QEMU_ARCH),i686)
58
    HOST_QEMU_ARCH = i386
59
endif
60
ifeq ($(HOST_QEMU_ARCH),powerpc)
61
    HOST_QEMU_ARCH = ppc
62
endif
63
HOST_QEMU_TARGETS=$(HOST_QEMU_ARCH)-linux-user
64
​
65
# Note: although QEMU has a ./configure script, it is not a real autotools
66
# package, and ./configure chokes on options such as --host or --target.
67
# So, provide out own _CONFIGURE_CMDS to override the defaults.
68
define HOST_QEMU_CONFIGURE_CMDS
69
    (cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure   \
70
        --target-list="$(HOST_QEMU_TARGETS)"    \
71
        --prefix="$(HOST_DIR)/usr"              \
72
        --interp-prefix=$(STAGING_DIR)          \
73
        --cc="$(HOSTCC)"                        \
74
        --host-cc="$(HOSTCC)"                   \
75
        --extra-cflags="$(HOST_CFLAGS)"         \
76
        --extra-ldflags="$(HOST_LDFLAGS)"       \
77
    )
78
endef
79
​
80
$(eval $(host-autotools-package))
81
​
82
# variable used by other packages
83
QEMU_USER = $(HOST_DIR)/usr/bin/qemu-$(HOST_QEMU_ARCH)
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.