• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/smstools3/smstools3.mk
Thomas De SchampheleireThomas De Schampheleire committed 9f8399c32a730 Apr 2014
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
################################################################################
#
# smstools3
#
################################################################################
​
SMSTOOLS3_VERSION = 3.1.15
SMSTOOLS3_SITE = http://smstools3.kekekasvi.com/packages/
SMSTOOLS3_LICENSE = GPLv2+
SMSTOOLS3_LICENSE_FILES = doc/license.html LICENSE
​
SMSTOOLS3_CFLAGS = $(TARGET_CFLAGS)
SMSTOOLS3_CFLAGS += -D NUMBER_OF_MODEMS=$(BR2_PACKAGE_SMSTOOLS3_NB_MODEMS)
SMSTOOLS3_CFLAGS += -D NOSTATS
​
define SMSTOOLS3_BUILD_CMDS
    $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(SMSTOOLS3_CFLAGS)" -C $(@D)
endef
​
define SMSTOOLS3_INSTALL_INIT_SYSV
    $(INSTALL) -m 0755 -D package/smstools3/S50smsd \
        $(TARGET_DIR)/etc/init.d/S50smsd
endef
​
define SMSTOOLS3_INSTALL_TARGET_CMDS
    $(INSTALL) -m 0755 -D $(@D)/src/smsd \
        $(TARGET_DIR)/usr/bin/smsd
    $(INSTALL) -m 0755 -D $(@D)/scripts/sendsms \
        $(TARGET_DIR)/usr/bin/sendsms
    $(INSTALL) -m 0644 -D $(@D)/examples/smsd.conf.easy \
        $(TARGET_DIR)/etc/smsd.conf
endef
​
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.