• Skip to sidebar navigation
  • Skip to content

Bitbucket

  • More
    ProjectsRepositories
  • Help
    • Online help
    • Learn Git
    • Welcome to Bitbucket
    • Keyboard shortcuts
  • Log In
Alexander Dahl
  1. Alexander Dahl

buildroot

Public
Actions
  • Clone
  • Compare

Learn more about cloning repositories

You have read-only access

Navigation
  • Source
  • Commits
  • Branches
  • All Branches Graph
  • Forks
  1. Alexander Dahl
  2. buildroot

Source

buildroot/package/zmqpp/zmqpp.mk
Alexander LukichevAlexander Lukichev committed 1f6934238a921 Jan 2014
Raw file
Source viewDiff to previous
xxxxxxxxxx
 
1
################################################################################
2
#
3
# zmqpp
4
#
5
################################################################################
6
​
7
ZMQPP_VERSION = 36413487f05b165dfc82ad307a5a1c36a795e607
8
ZMQPP_SITE = git://github.com/benjamg/zmqpp.git
9
ZMQPP_INSTALL_STAGING = YES
10
ZMQPP_DEPENDENCIES = zeromq
11
ZMQPP_LICENSE = LGPLv3+ with exceptions
12
ZMQPP_LICENSE_FILES = COPYING COPYING.LESSER
13
​
14
ZMQPP_MAKE_OPT = LD="$(TARGET_CXX)" BUILD_PATH=./build PREFIX=/usr
15
ZMQPP_LDFLAGS = $(TARGET_LDFLAGS) -lpthread
16
​
17
ifeq ($(BR2_PACKAGE_ZMQPP_CLIENT),y)
18
ZMQPP_DEPENDENCIES += boost
19
endif
20
​
21
define ZMQPP_BUILD_CMDS
22
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
23
        LDFLAGS="$(ZMQPP_LDFLAGS)" \
24
        $(ZMQPP_MAKE_OPT) $(if $(BR2_PACKAGE_ZMQPP_CLIENT),all) -C $(@D)
25
endef
26
​
27
define ZMQPP_INSTALL_TARGET_CMDS
28
    $(INSTALL) -m 0755 -d $(TARGET_DIR)/usr/include/zmqpp
29
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
30
        $(ZMQPP_MAKE_OPT) DESTDIR=$(TARGET_DIR) install -C $(@D)
31
endef
32
​
33
define ZMQPP_INSTALL_STAGING_CMDS
34
    $(INSTALL) -m 0755 -d $(STAGING_DIR)/usr/include/zmqpp
35
    $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
36
        $(ZMQPP_MAKE_OPT) DESTDIR=$(STAGING_DIR) install -C $(@D)
37
endef
38
​
39
$(eval $(generic-package))
  • Git repository management for enterprise teams powered by Atlassian Bitbucket
  • Atlassian Bitbucket v6.7.2
  • Documentation
  • Request a feature
  • About
  • Contact Atlassian
Atlassian

Everything looks good. We'll let you know here if there's anything you should know about.